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Introduction 
 

This document details the steps required to configure Active Directory for use 

with a cloud hosted Impero Education Pro Server. Impero Education Pro will 

communicate to the customers domain controller using the Lightweight 

Directory Access Protocol over Secure Socket Layer (LDAPS). This ensures that 

any data transmitted between the Domain Controller and Impero Education Pro 

is encrypted using SSL. This will allow some of the features within Impero to 

interact with customers active directory such as change password. 

 

Pre Requisites 
 

The below will be needed to get the LDAP’s configuration working; 

• The following firewall configuration is required only for the Domain 

Controller that Impero will be contacting over LDAPS.** The Domain 

controller will need to be publicly accessible either via a DMZ or by Port 

Forwarding.  

Protocol Port Traffic Direction Rule 
TCP 636 Inbound & 

Outbound 
Allow 

TCP 389 Inbound & 
Outbound 

Block* 

*blocking 389 is not a requirement but advised so that there will be no attempt 

to transmit information across this port. 

** This is in addition to the usual Impero Exclusions. 

• We advise if you are not already using LDAP’s for other reasons that you 

restrict the communication to our servers. 

 

• Please take note of your Domain Controllers FQDN (Fully Qualified 

Domain Name) and your Public IP address as this will be required later. 

 

• We advise creating a service account in an active directory such as 

Impero-Admin who has the permission to be able to change password 

etc... (Account Operators) as we will need the username and password 
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for authentication purposes but is not essential, this will be described and 

set up later in this guide. 

 

• You will need to be able to create/generate certificates on the domain 

controller. 

 

Certificate Setup 
 

In the next following steps, we are going to be setting up the Certificates so that 

the Impero Services and your domain controller can communicate with each 

over SSL. 

 

Install Active Directory Certificate Services (AD CS) 
 

1. Open the 'Start' screen - this can be accessed from the bottom left of the 

desktop or by pressing the Windows key. 

2. Search for 'Server Manager' and click to open it. 

3. Click 'Manage' in the top left of the Server Manager. 

4. Click 'Add Roles and Features' (Image 1). 

 

5. The 'Add Roles and Features Wizard' should open. 

6. Click 'Next' on the 'Before you Begin' screen. 
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7. Click 'Next' on the 'Installation Type' screen. 

8. Click 'Next' on the 'Server Selection' screen. 

9. Tick 'Active Directory Certificate Services' and an additional window 

should appear (Image 1.1). 

 

10. Click 'Add Features'. 

11. Click 'Next' on the 'Server Roles' screen. 

12. Click 'Next' on the 'Features' screen. 

13. Click 'Next' on the 'AD CS' screen. 

14. Ensure that 'Certification Authority' is ticked (Image 1.2). 
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15. Click 'Next'. 

16. Click 'Install' on the 'Confirmation' screen. 

17. Wait for the installation to complete. 

18. Click 'Configure Active Directory Certificate Services on the destination 

server' on the 'Results' screen (Image 1.3). 

19. The 'AD CS Configuration' window should open. 

20. Confirm that you are using an administrator account which is a member 

of the Enterprise Admins group. If not, please select 'Change...' and enter 

the credentials of an account with membership to the Enterprise Admins 

group. 

21. Click 'Next' on the 'Credentials' screen. 

22. Tick 'Certification Authority' (Image 1.4). 
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23. Click 'Next' on the 'Role Services' screen. 

24. Confirm that 'Enterprise CA' is selected (Image 1.5). 

 

25. Click 'Next' on the 'Setup Type' screen. 

26. Confirm that 'Root CA' is selected (Image 1.6). 
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27. Click 'Next' on the 'CA Type' screen. 

28. Confirm that 'Create a new private key' is selected (Image 1.7). 

 

29. Click 'Next' on the 'Private Key' screen. 

30. Click 'Next' on the 'Cryptography' screen. 

31. Click 'Next' on the 'CA Name' screen. 

32. Confirm that the validity period is set to '5 years' *this is custom and will 

require this step to be redone on expiry (Image 1.8). 

 

33. Click 'Next' on the 'Validity Period' screen. 

34. Click 'Next' on the 'Certificate Database' screen. 

35. Click 'Configure' on the 'Confirmation' screen. 

36. Wait for the configuration process to complete. 

37. Click 'Close' on the 'Results' screen. 

38. Click 'Close' on the 'Add Roles and Features Wizard'. 

The Domain Controller CA Certificate has now been created. 
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Create an Impero LDAPS Certificate Template 
 

1. Open the 'Start' screen/menu. 

2. Search for 'certsrv.msc' and click to open it. 

3. Expand the entry containing the server name under 'Certification 

Authority (Local)'. 

4. Right-click on 'Certificate Templates'. 

5. Click 'Manage' (Image 2). 

 

6. The 'Certificate Templates Console' should open. 

7. Right-click 'Kerberos Authentication' from the list. 

8. Click 'Duplicate Template' (Image 2.1). 

 

The Kerberos Authentication is a protocol this is used for authenticating the 

requests between the Impero Service and your Domain Controller across the 

untrusted network. 
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9. The 'Properties of New Template' window should open 

10. Click on the 'General' tab 

11. Change the 'Template display name' to 'Impero-LDAPS' 

12. Change the 'Validity period' to '5 years' (Image 2.2) 

13. Change the 'Renewal period' to '3 years' (Image 2.2) 

 

14. Click on the 'Subject Name' tab 

15. Tick 'DNS name' and 'Service Principal Name (SPN)' (Image 2.3) 
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16. Click 'Apply'. 

17. Click 'OK'. 

18. Close the 'Certificate Templates Console' and return to 'certsrv’. 

19. Right-click 'Certificate Templates'. 

20. Click 'New -> Certificate Template to Issue' (Image 2.4); 

 

21. The 'Enable Certificate Templates' window should open. 
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22. Select 'Impero-LDAPS' from the list (Image 2.5). 

 

Impero 2.5 - Certificate Templates 1 

23. Click 'OK'. 

24. Close the 'Certsrv' window. 
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Request Certificate for Server Authentication 
 

1. Open the 'Start' screen. 

2. Search for 'MMC.exe' and click to open it. 

3. Click on the 'File' menu in the top left. 

4. Click 'Add/Remove Snap-in...'. 

5. The 'Add or Remove Snap-ins' window should open. 

6. Select 'Certificates' from the left pane (Image 3); 

 

7. Click 'Add >'. 

8. The 'Certificates snap-in' window should open. 

9. Tick 'Computer account'. 

10. Click 'Next'. 

11. Click 'Next'. 

12. Click 'OK'. 

13. Expand 'Certificates (Local Computer)'. 

14. Right-click 'Personal'. 

15. Click 'All Tasks -> Request New Certificate...' (Image 3.1). 
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16. The 'Certificate Enrollment' window should open. 

17. Click 'Next'. 

18. Confirm that the 'Active Directory Enrollment Policy' is selected (Image 

3.2). 

 

19. Click 'Next'. 

20. Tick 'Impero-LDAPS' (Image 3.3); 
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21. Click 'Enroll'. 

22. Wait for the enrolment to complete. 

23. Click 'Finish'. 
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Export Certificates for LDAPS 
 

1. Open the 'Start' screen 

2. Search for 'MMC.exe' and click to open it 

3. Click on the 'File' menu in the top left 

4. Click 'Add/Remove Snap-in...' 

5. The 'Add or Remove Snap-ins' window should open 

6. Select 'Certificates' from the left pane 

7. Click 'Add >' 

 

8. The 'Certificates snap-in' window should open 

9. Tick 'Computer account' 

10. Click 'Next' 

11. Click 'Next' 

12. Click 'OK' 

13. Expand 'Certificates (Local Computer)' 

14. Expand 'Personal' 

15. Select 'Certificates' from the left-hand tree view 

16. Locate the certificate with the FQDN of the Domain Controller under 

'Issued To' and 'Impero-LDAPS' under 'Certificate Template' 

17. Right-click on the certificate 

18. Click 'All Tasks -> Export' 
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19. The 'Certificate Export Wizard' should open 

20. Click 'Next' 

21. Click 'Next' 

22. Confirm that 'DER encoded binary X.509(.CER)' is selected 

 

23. Click 'Next' 

24. Click 'Browse...' 

25. Select a location to export the certificate to and enter the server name as 

the file name e.g. IMPDC01 on C:\Certs 
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26. Click 'Save' 

27. Click 'Next' 

28. Click 'Finish' 

29. A window should appear confirming the export was successful 

30. Click 'OK' 

31. Within the MMC 'Certificates' view, locate the certificate with '-CA' at the 

end under 'Issued To' 
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32. Right-click on the certificate 

33. Click 'All Tasks -> Export' 

34. The 'Certificate Export Wizard' should open 

35. Click 'Next' 

36. Select 'Yes, export the private key' 

37. Click 'Next' 

38. Tick 'Export all extended properties' and 'Include all certificates in the 

certification path if possible'. 
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39. Click 'Next' 

40. Tick 'Password: 

41. Enter a strong password (Please take note of this as it will be required 

later); 

 

42. Click 'Next' 

43. Click 'Browse...' 

44. Navigate to the same folder you saved the server certificate to 

45. Enter the server name with '-CA' at the end as the file name e.g. 

IMPDC01-CA 

46. Click 'Save' 

47. Click 'Next' 

48. Click 'Finish' 

49. A window should appear confirming the export was successful 

50. Click 'OK' 

51. Close the 'MMC.exe' window 
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Create User Account for authenticating with LDAPS 
 

1. Open the 'Start' screen 

2. Search for 'dsa.msc' and click to open it 

3. 'Active Directory Users and Computer' should open 

4. Navigate to the root Organisational Unit containing all of your users e.g. 

All Users 

For example (You can create this user at the domain root level if you wish:  

Teaching Staff user accounts are located in a 'Teaching Staff' OU, which is a 

child of the 'All Users' OU  

All Users -> Teaching Staff  

Student user accounts are located in an OU related to their year group, 

which in turn is located within a 'Students' OU, which is a child of the 'All 

Users' OU 

All Users -> Students -> Year 12  

In this example, the 'All Users' OU would be identified as the root OU. 

5. Right-click on the root OU identified above 

6. Click 'New -> User' 

7. The 'New Object' window should appear 

8. In 'First name:' enter 'Impero' 

9. In 'Last name:' enter 'Admin' 

10. In 'User logon name:' enter 'Impero-Admin'; 
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11. Click 'Next' 

12. Enter a strong password without any ASCII special characters Note : 

These are the ASCII special characters that should NOT be used when 

creating the Impero-Admin password; 

, . / < > ? ; ' : " [ ] { } \ | ! @ # $ % ^ & * ( - = _ +  
This is due to incompatibility with specific services. Use uppercase characters, 
lowercase characters and numbers only. 
 

13. Untick 'User must change password at next logon' 

14. Tick 'User cannot change password' 

15. Click 'Next' 

16. Click 'Finish' 

17. Click on the 'View' menu within Active Directory Users and Computers 

18. Click 'Advanced Features' to enable the option; 
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19. Right-click the 'Impero-Admin' user 

20. Click 'Properties' 

21. In the 'Email:' field enter a unique email address e.g. 

imperoadmin@imperosoftware.com (This does not need to be a real 

account) 

22. Click 'Apply' 

23. Click on the 'Attribute Editor' tab 

24. Click 'Filter' 

25. Confirm that 'Show only attributes that have values' is ticked Impero-

Admin  

26. Take note of the following attribute values as these will be required later; 

Attribute Example 

distinguishedName CN=ldaps test,DC=uktest,DC=com 

mail ldapstest@imperosoftware.com 

userPrincipalName ldapstest@uktest.com 

 
27. Click on the 'Member Of' tab 

28. Click 'Add...' 

29. In the 'Enter the object names to select' field type 'Domain Admins & 

Account Operators' 

30. Click 'OK' 

31. Click 'Apply 
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The user will now have Domain and Account Control privileges required for 

some features in Impero such as change password. 

 

Verify local LDAPS connectivity 
 

We need to verify that we can connect to the domain controller locally to make 

sure this is now all working correctly. 

1. Open the 'Start' screen 

2. Search for 'LDP.exe' and click to open it 

3. Click on the 'Connection' menu in the top-left 

4. Click 'Connect...' 

 

5. Under 'Server:' type the FQDN of the Domain Controller e.g. 

IMPDC01.IMPEROSOFTWARE.COM 

6. Under 'Port:' type '636' 

7. Tick 'SSL' 
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8. Click 'OK' 

9. Click on the 'Connection' menu 

10. Click 'Bind...' 

11. Under 'Bind type' select 'Bind with credentials' 

12. Under 'User:' enter 'Impero-Admin' (The user created earlier) 

13. Under 'Password:' enter the strong password you assigned the user 

14. Under 'Domain:' enter your full domain name e.g. imperosoftware.com; 
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15. Click 'OK' 
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16. Observe the output in the ldp.exe tool 

To confirm we can communicate via SSL and via the Authenticated User you 

should see the following lines highlighted; 
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Contact Impero 
 

Now this is all setup and confirmed that we can communicate locally you need 

to contact Impero so they can do their side of the setup. 

The following information will be needed, which advise to send in separate 

emails directly to the Agents email address who your dealing with, if you don’t 

have these details you can call Impero support. 
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If you prefer to not email the details below you could put all this in a shared 

location and share a Link such as Google Drive, OneDrive etc… 

 

 

Email Subject Contents Attachments 

1 ImperoLdaps-YourSchoolName-S1 
Your Domain Controllers 

Public IP Addresses’ 
None 

2 ImperoLdaps-YourSchoolName-S2 
Domain Controller CA 
Certificate Password 

(Page 15 of this guide) 

Domain Controller 
server (.cer) certificate. Which 
Needs to be .zip to get around mail 
filters 

3 ImperoLdaps-YourSchoolName-S3 

Impero-Admin user 
details:  
distinguishedName  
mail  
userPrincipalName 

Domain Controller CA (.pfx) 
certificate. Which Needs to be .zip to 
get around mail filters 

4 ImperoLdaps-YourSchoolName-S3 
ImperoAdmin user 
password 

None 
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info@imperosoftware.com 

www.imperosoftware.co.uk 

www.imperosoftware.com 

+44 (0) 1509 611341 UK 

877-883-4370 USA 
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