Depending on the activity of your users you may have a lot of logging information that appears in the Log Viewer in the Impero system, or you may have been an Impero customer for some time in which you may have accumulated a considerable amount of .ilog2 files in this default location;

C:\Program Files (x86)\Impero Solutions Ltd\Impero Server\Data\Logs



As you can see the log files are dated and depending on your school policy you will have to keep these log files, however, having them all connected to the Impero Server can possibly reduce the performance.

We suggest that you "Attach" the Log files that you want to see all the time such as the academic year or past 6 months in the log viewer or "Detach" Log files that you no longer want to be connected (Not deleted) which can be reconnected at a future date when needed.


See below for more information on the processes above;


Attaching an archived / older log file;


To Attach an archived or an older log file that is not currently in the system you will need to open the Impero Server Application and navigate to Tools -> Datafiles -> Datafile Viewer


Once in the DataFile viewer, you will see a list of all the connected logfiles that are attached to the system and you will be able to see the Start and End day for the individual log files.

To add an Archived or older log file you will need to click Datasources -> Add existing datafile which will open an explorer window in which you will need to find and open the desired log file.



Once you have selected the logfile this will now be added to the Impero Server, to see it in the Datasource viewer you will need to click Datasources -> Refresh and you will see it appear in the list, depending on the size of the file you may notice it says 0kb, once the log file has imported which can take 2 - 10 mins depending on the size you can refresh the window again to update the view. 


Once the log file has been imported you will see the new dates in the LogViewer or Capture Management



Detaching a current attached LogFile;


If you are seeing older dates that you don't really need in the LogViewer you can detach these specific log files from the system (Which doesn't delete them) and reimport at a later time if needed.


To do this you will need to navigate to the Datafile Viewer on the Impero Server Tools -> Datafiles -> Datafile Viewer

Once in the DataFile viewer, you will see a list of all the connected logfiles that are attached to the system and you will be able to see the Start and End day for the individual log files.

Next to the individual log files, you can click "Options" -> Remove which will unlink the LogFile but still keep the data stored on the Impero Server.



Once the file has been removed you can click Datasources -> Refresh and you will see that this has now been removed.